[Mongrel] Mongrel, cross compilation, Echoe and rake-compiler

Luis Lavena luislavena at gmail.com
Sun Apr 26 20:32:01 EDT 2009


Hello Guys, mainly Evan,

With the goal to move One-Click Ruby Installer to use MinGW (GCC)
compiler, I found there is no binary for mongrel for that platform.

Because of that, the migration for lot of folks will require install
the development toolkit, which I'm trying to avoid.

Being the maintainer of the Windows builds of Mongrel, been wanted to
upgrade it to use rake-compiler project.

rake-compiler has been out for a while, and several projects has been
migrated to it successfully, including ruby-ffi, johnson, nokogiri and
others.

Now, a few questions before I invest a lot of time with mongrel repository.

I'm working over "master" at fauna repository:

http://github.com/fauna/mongrel

My plan is the following:

Ensure both current and new One-Click works with Mongrel.
Ensure building binaries for it either native or cross platform works flawlessly

Now, I have a few blockers:

Dunno which branch is the proper one. last time I worked on 1.2
improving MinGW support and 1.1.5 got out without taking those
patches.

Echoe extension compilation is interfering with rake-compiler one, is
there a way to disable it?

Elliot Cable left a message when I first imported rake-compiler to GitHub:

http://github.com/luislavena/rake-compiler/commit/28e938cf837c6859197000cc647f84f92668f0b6#comments

Again, the goal of rake-compiler is not just simplify the compilation,
but also provide something that Echoe or Hoe doesn't: cross
compilation.

Well, I've shared my plan, what do you guys think?

Cheers,
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Mongrel-users mailing list