[Mongrel] Error when install Mongrel as a Windows service

Luis Lavena luislavena at gmail.com
Tue Sep 16 19:25:58 EDT 2008

On Tue, Sep 16, 2008 at 6:01 PM, Sophie Su <lists at ruby-forum.com> wrote:
> I have Ruby and Rails 2.1.1 installed, then I installed mongrel 1.1.5.
> Now I want to install mongrel as a service. I downloaded and installed
> mongrel_service-0.3.3-mswin32.gem. After all these, I followed the
> instructions to install it as service by running the command below, but
> got an error.

Did you install mongrel_service using RubyGems locally or remote?

If you downloaded the gem and installed locally then the win32/service
dependency will not be fulfilled.

mongrel_service requires a specific version of that win32-service gem
>= 0.5.2 and less than 0.6, since that version introduced some
incompatibilities that require a lot of code change in the plugin.

Luis Lavena
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams

More information about the Mongrel-users mailing list