[Mongrel] Error when install Mongrel as a Windows service

Sophie Su lists at ruby-forum.com
Tue Sep 16 17:01:11 EDT 2008


I have Ruby and Rails 2.1.1 installed, then I installed mongrel 1.1.5.
Now I want to install mongrel as a service. I downloaded and installed
mongrel_service-0.3.3-mswin32.gem. After all these, I followed the
instructions to install it as service by running the command below, but
got an error.

C:\ruby>mongrel_rails service::install -N BuildDashboard -c "c:\Build
Dashboard" -p 4000 -e development

c:/ruby/lib/ruby/gems/1.8/gems/mongrel_service-0.3.3-mswin32/lib/mongrel_service/init.rb:140:in
`initialize':

wrong number of arguments (0 for 1) (ArgumentError)

        from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel_service-0.3.3-mswin32/lib/mongrel_service/init.rb:140:in
`new'

        from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel_service-0.3.3-mswin32/lib/mongrel_service/init.rb:140:in
`run'

        from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/command.rb:212:in
`run'

        from
c:/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:281

        from c:/ruby/bin/mongrel_rails:16:in `load'

        from c:/ruby/bin/mongrel_rails:16

Thanks for any help.
-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list