[Mongrel] problem starting mongrel in windows

suman gurung(hotmail) gurung_suman at hotmail.com
Sat Sep 6 23:29:42 EDT 2008

Thanks, Luis, for making me see that. Indeed I was using jruby's gems to 
install all the applications. When I installed anything using the gem 
command, it was the gem under the jruby folder that was being executed. I 
had to changed the precedence of the entries of jruby and ruby in the 
path(environment variable) and do all the installs again and mongrel runs 


From: "Luis Lavena" <luislavena at gmail.com>
Sent: Saturday, September 06, 2008 3:08 PM
To: <mongrel-users at rubyforge.org>
Subject: Re: [Mongrel] problem starting mongrel in windows

> On Fri, Sep 5, 2008 at 7:56 PM, suman gurung(hotmail)
> <gurung_suman at hotmail.com> wrote:
>> Hi everybody,
>> I was trying to get rails applications deployed in my pc(windows vista), 
>> and
>> I had some problem trying to start mongrel web server, and I have no clue 
>> as
>> to how and why it is not working.
>> I have installed ruby, rubygems, rails, mysql and mongrel, the last three 
>> as
>> rubygems. I could run the 'rails' command to and create an application 
>> with
>> the folder structure and all. But when I tried to start the mongrel, I 
>> get
>> the following error message.
>> F:\ROR\sources\hello>mongrel_rails start -d
>> C:/ruby/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
>> `require': no such file to load -- win32/service (LoadError)
>>         from
>> C:/ruby/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.
>> rb:27:in `require'
>>         from
>> C:/ruby/jruby-1.1.3/lib/ruby/gems/1.8/gems/mongrel_service-0.1/lib/mongrel_service/init.rb:5
>>         from
>> C:/ruby/jruby-1.1.3/lib/ruby/gems/1.8/gems/mongrel_service-0.1/lib/mongrel_service/init.rb:27:in
>> `require'
> To keep it short:
> You're using JRuby, not Matz Ruby (MRI) so:
> mongrel_service gem will not work, since it depends on win32-service,
> which is only Windows (not Java).
> You're using a old version of mongrel_service (0.1) which definitely
> will not work as expected with latest Rails and Mongrel.
> Daemonize (-d) otpion requires fork functionality, which is not
> available in Windows (neither MRI or JRuby or any Ruby for Windows
> implementation).
>> Also, is there any way to keep mongrel live and running?? I tried to 
>> install
>> it as a service as mentioned in the website with the following command: 
>> gem
>> install mongrel_service and it mentioned that 1 gem was installed, but I
>> don't see any service with the name "mongrel" or "mongrel_rails" running 
>> in
>> the list of services. I am new with mongrel so please do help me.
> mongrel_rails service::install --help
> That is clearly documented in mongrel site:
> http://mongrel.rubyforge.org/wiki/Win32
> -- 
> Luis Lavena
> AREA 17
> -
> Human beings, who are almost unique in having the ability to learn from
> the experience of others, are also remarkable for their apparent
> disinclination to do so.
> Douglas Adams
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users

More information about the Mongrel-users mailing list