[Mongrel] problem starting mongrel in windows

suman gurung(hotmail) gurung_suman at hotmail.com
Fri Sep 5 18:56:52 EDT 2008


Hi everybody,
I was trying to get rails applications deployed in my pc(windows vista), and I had some problem trying to start mongrel web server, and I have no clue as to how and why it is not working.
I have installed ruby, rubygems, rails, mysql and mongrel, the last three as rubygems. I could run the 'rails' command to and create an application with the folder structure and all. But when I tried to start the mongrel, I get the following error message. 

F:\ROR\sources\hello>mongrel_rails start -d
C:/ruby/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require': no such file to load -- win32/service (LoadError)
        from C:/ruby/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.
rb:27:in `require'
        from C:/ruby/jruby-1.1.3/lib/ruby/gems/1.8/gems/mongrel_service-0.1/lib/mongrel_service/init.rb:5
        from C:/ruby/jruby-1.1.3/lib/ruby/gems/1.8/gems/mongrel_service-0.1/lib/mongrel_service/init.rb:27:in `require'
        from C:/ruby/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from C:/ruby/jruby-1.1.3/lib/ruby/gems/1.8/gems/gem_plugin-0.2.3/lib/gem_plugin.rb:134:in `load'
        from C:/ruby/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:195:in `each'
        from C:/ruby/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:195:in `each'
        from C:/ruby/jruby-1.1.3/lib/ruby/gems/1.8/gems/gem_plugin-0.2.3/lib/gem_plugin.rb:112:in `load'
        from C:/ruby/jruby-1.1.3/lib/ruby/gems/1.8/gems/mongrel-1.1.5-java/bin/mongrel_rails:278
        from C:/ruby/jruby-1.1.3/lib/ruby/gems/1.8/gems/mongrel-1.1.5-java/bin/mongrel_rails:19:in `load'
        from c:\ruby\jruby-1.1.3\bin\mongrel_rails:19


Also, is there any way to keep mongrel live and running?? I tried to install it as a service as mentioned in the website with the following command: gem install mongrel_service and it mentioned that 1 gem was installed, but I don't see any service with the name "mongrel" or "mongrel_rails" running in the list of services. I am new with mongrel so please do help me. 

Thanks, 
suman gurung
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/mongrel-users/attachments/20080905/0b54b646/attachment.html>


More information about the Mongrel-users mailing list