[Mongrel] mongrel_service problems

Luis Lavena luislavena at gmail.com
Wed Oct 8 20:30:56 EDT 2008


On Wed, Oct 8, 2008 at 6:44 PM, Glen Holcomb <damnbigman at gmail.com> wrote:
> I have installed mongrel_service and created a service instance with the -l
> flag and the -B flag but I still don't get any useful feedback.
>
> When trying to connect to my server via Apache I get a 503 error and when
> connecting directly (http://127.0.0.1:3000) I get a timeout.
>
> The files.log just has a list of log files in it for each request and the
> rest of the log files have nothing but lines saying TRACING but nothing that
> looks like info to me.
>
> The log file I specified in the -l flag isn't appearing.  I've tried giving
> the full path and file name and I've tried a relative path
> "log/mongrel_service.log"
>
> What am I doing wrong?
>

Right now mongrel_service has a huge drawback: it doesn't let you log
to different files.

Blame me, blame the no argument parsing of the redirected terminals :-P

Did you tried executing your application with mongrel_rails standalone
instead of the service first?

Also, you can "mimic" what the service does from the terminal, asi
described previous in several threads in this list (search google for
mongrel_service debug console).

Here some pointer:

http://rubyforge.org/pipermail/mongrel-users/2007-February/003004.html

I should definitely collect a list of that stuff and make a blog post :-P

-- 
Luis Lavena
AREA 17
-
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams


More information about the Mongrel-users mailing list