[Mongrel] mongrel and fastthread on ruby 1.9?

Luis Lavena luislavena at gmail.com
Sun Nov 23 10:17:05 EST 2008


On Fri, Nov 21, 2008 at 11:02 PM, Joe Carroll <lists at ruby-forum.com> wrote:
> Luis Lavena wrote:
>> These corrections where merged to trunk and are available under
>> --disable-fastthread option of configure.
>>
>> Also, ruby 1.8.6 ships with these changes, so dependency of fastthread
>> is only required for ruby < 1.8.6
>
> At what stage in the installation process of which component can I
> specify this flag? Do I need to specify it when invoking configure
> before compiling Ruby 1.9.1 from source? And does anyone know if Mongrel
> will successfully install and run afterwards? And how likely is it that
> disabling fastthread will break other things?

When compiling ruby from source (either 1.8.6 or 1.9) both get
fastthread enabled by default, you need to explicitly disable it in
case that you don't want it (which I will doubt).

So unless you depend on a package made by debian which they decided
not to enable that helpful flag, you will not need to worry.

Again, modern Ruby no need for fastthread (is built-in in ruby) so
mongrel will remove fastthread from the dependency and required if
present.

That sounds better explanation?

-- 
Luis Lavena
AREA 17
-
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams


More information about the Mongrel-users mailing list