[Mongrel] Mongrel error since updating to OSX 10.5.3

Matt Daw matt at shotgunsoftware.com
Fri May 30 13:55:41 EDT 2008


Hi Woody, thanks, that fixed it for me. That explains the difference  
in my app, the newer branches are on an up to date backgroundrb, while  
the broken one is still on an ancient one.

Matt

On 30-May-08, at 1:47 PM, Woody Woahdae wrote:

> Matt Daw wrote:
>> Howdy, I'm getting an error message when trying to run one of my  
>> rails
>> apps, which seems to have started after updating to 10.5.3.
>>
>> mattdaw-2:v1.5_patch mdaw$ mongrel_rails start
>> ** Starting Mongrel listening at 0.0.0.0:3000
>> ** Starting Rails with development environment...
>> /usr/local/ruby-patched/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../
>> lib/mongrel/tcphack.rb:12:in `initialize_without_backlog':
>> getaddrinfo: nodename nor servname provided, or not known  
>> (SocketError)
>
> If you try running a migration it gives a better stack trace, and I
> tracked it down to backgroundrb/drb. I'm using an older version of
> backgroundrb, and on line 67 of
> vendor/plugins/backgroundrb/lib/backgroundrb.rb it calls
> DRb.start_service('druby://localhost:0'). I changed that to
> DRb.start_service(nil), which finds the first open port, and it starts
> up. I haven't tested this at all, let alone in a production  
> environment,
> but I will have in a few days. I'd be interested to know if this is  
> all
> it takes to solve your problem too.
>
> -- 
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users



More information about the Mongrel-users mailing list