[Mongrel] gem install of mongrel v 1.1.5 broken in jruby

Evan Weaver evan at cloudbur.st
Thu May 22 16:10:43 EDT 2008


Yeah, I still have do JRuby 1.1.5. I will do it tonight.

Evan

On Thu, May 22, 2008 at 3:59 PM, Filipe Lautert <filipe at icewall.org> wrote:
>
> I'm not sure, but I think Evan is realising this now.
>
> Cheers,
>
> filipe
> On Thu, 22 May 2008, Stephen Bannasch wrote:
>
>> Can't install the latest mongrel (1.1.5) in JRuby (jruby revisions ranging
>> from 6600 to 6750[trunk] checked) -- the platform is not being identified
>> and it's trying to do native compilation.
>>
>> I'm not sure it's actually a problem with Mongrel or JRuby however --
>> perhaps there isn't a mongrel-1.1.5-java.gem on rubyforge?
>>
>> Some investigation below:
>>
>> $ jruby -S gem install mongrel
>> JRuby limited openssl loaded. gem install jruby-openssl for full support.
>> http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
>> Bulk updating Gem source index for: http://gems.rubyforge.org/
>> Building native extensions.  This could take a while...
>> extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
>>        from extconf.rb:1
>> ERROR:  Error installing mongrel:
>>        ERROR: Failed to build gem native extension.
>>
>> Installing 1.1.4 works fine.
>>
>> $ jruby -S gem install mongrel -v 1.1.4
>> JRuby limited openssl loaded. gem install jruby-openssl for full support.
>> http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
>> Successfully installed mongrel-1.1.4-java
>> 1 gem installed
>> Installing ri documentation for mongrel-1.1.4-java...
>> Installing RDoc documentation for mongrel-1.1.4-java...
>>
>> Specifying the platform in the gem command does not help:
>>
>>  $ jruby -S gem install mongrel --platform java
>>  $ jruby -S gem install mongrel --platform jruby
>>
>> same error.
>>
>> I don't see a tag for 1.1.5:
>>
>>  http://mongrel.rubyforge.org/browser/tags
>>
>> mongrel 1.1.4 is r985 and this is the only change in the Rakefile since
>> then:
>>
>>  http://mongrel.rubyforge.org/changeset/997/trunk/Rakefile
>>
>> Don't see how that would be a problem.
>>
>> _______________________________________________
>> Mongrel-users mailing list
>> Mongrel-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/mongrel-users
>>
>
> filipe {
>  @              icewall.org
>  GPG         1024D/A6BA423E
>  http://filipe.icewall.org/
> }
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>



-- 
Evan Weaver


More information about the Mongrel-users mailing list