[Mongrel] patched ruby seems to break mongrel?

Luis Lavena luislavena at gmail.com
Mon Jun 23 15:38:01 EDT 2008

On Mon, Jun 23, 2008 at 9:02 PM, John Weir <john at smokinggun.com> wrote:
>> Also, 1.8.7 is a little shaky right now; I recommend avoiding it.
> This is off topic, but can your or Luis provide some information, or links,
> on what makes 1.8.7 "shaky" or unsuitable for production?

1.8.7 backported lot of stuff from 1.9, which broke RubySpec:


At the end something of this was solved, but there are still some
guards around some 1.8.7 specific stuff.

1.8.7 also introduced bugs for some GUI tools, like wxRuby:


Regarding the patchelevel stuff, the own tests for ruby don't pass, as
I commented here:


So I cannot provide an updated version of One-Click Installer for
1.8.7 or 1.8.6-p230 if:

1.8.7 break packages that OCI bundles (wxRuby) and p230 cannot
complete it's own tests...

> thank you very much - jw

No problem, take care!.
Luis Lavena
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams

More information about the Mongrel-users mailing list