[Mongrel] Fresh install on Debian Etch - Mongrel immediately hangs

Emmett Shear emmett.shear at gmail.com
Fri Jun 6 21:03:51 EDT 2008


I just had the same exact problem with the same solution. The wrong platform
of fastthread was installed, which was causing mongrel to spin. That should
probably dump with a stacktrace instead of spinning, I'll see if I can learn
enough mongrel to write a patch.

Emmett

On Mon, Dec 17, 2007 at 2:43 AM, Paolo Capriotti <lists at ruby-forum.com>
wrote:

> Luis Lavena wrote:
> > On Dec 17, 2007 6:15 AM, Paolo Capriotti <lists at ruby-forum.com> wrote:
> > [...]
> >>
> >> I've found that mongrel tries to require some library repeatedly,
> >> because it gets an unrelated exception while trying to load it. For me,
> >> the missing library was actually fastthread, and installing it solved
> >> the problem.
> >> To find out what is the actual error, add a print statement after line 8
> >> in lib/mongrel/gems.rb.
> >>
> >> Hope that helps,
> >>
> >
> > Paolo, you can confirm this behavior happens also with "mongrel_rails"
> > and not just script/server?
>
> Yes, it did happen. After installing fastthread, I can't reproduce it
> anymore if I uninstall it. mongrel_rails now exits with a clean
> backtrace when started without fastthread installed, and script/server
> runs webrick instead.
> I don't know what exactly was causing the problem... maybe a wrong
> installed version of fastthread? The exception caught in
> lib/mongrel/gems.rb:8 was:
> 'no such file to load -- fastthread' - sorry, I didn't save the
> backtrace.
>
> Paolo Capriotti
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/mongrel-users/attachments/20080606/7c14cb66/attachment-0001.html>


More information about the Mongrel-users mailing list