[Mongrel] fastthread no longer needed?

MenTaLguY mental at rydia.net
Wed Jan 2 14:57:47 EST 2008

On Wed, 2 Jan 2008 20:05:13 +0100, "David Vrensk" <david at vrensk.com> wrote:
> I hope I'm wrong here, but the way I understand what you're saying is that
> Mongrel will stop patching Ruby once Mongrel is ready to run on Ruby 1.9.
> Wouldn't that mean that you at the same time removed support for all Ruby
> versions below 1.8.6 p36?

Well, I'd hope what he meant was that Mongrel would still use fastthread if
it was installed, but it would no longer be a dependency of the Mongrel gem.

Which would be as it ought to be -- my intent was for fastthread to fill the
gap between 1.8 and 1.9, and then eventually go away once people stopped
needing/installing it.  But the folks on 1.8.x aren't going away for a while,
so I think it's important that Mongrel uses it if it is installed/supported.


More information about the Mongrel-users mailing list