[Mongrel] Mongrel does not restart after cap deploy

Michael D'Auria michael.dauria at gmail.com
Fri Feb 15 10:57:00 EST 2008


I would check that you have all the proper gems installed on the
server.  Is your dev machine the same os and version as your
production?



On 2/14/08, Nate Vick <nvick77 at gmail.com> wrote:
> Thanks for the response. I have check the path and as far as I can tell it
> is all set. I did try adding default_environment to my capfile to define the
> path to ruby with no change.
> Should I be define the path in my reaper script?
>
> On Mon, Feb 11, 2008 at 9:11 AM, Michael D'Auria <michael.dauria at gmail.com>
> wrote:
>
> > Nate,
> >
> > Sounds like your script doesn't define the correct path.  I compile ruby
> > so it's under /usr/local/lib/ruby.
> >
> > Michael
> >
> > On Feb 11, 2008 11:39 AM, Nate Vick <nvick77 at gmail.com> wrote:
> >
> > > I get the following error when I try to deploy my first application.
> > > /usr/lib/ruby/gems/1.8/gems/mongrel-1.1/bin/mongrel_rails:18:
> > > uninitialized constant Mongrel::GemPlugin (NameError)
> > >
> > > I have a script in /etc/init.d that restarts mongrel and uses the reaper
> > > script to do so. Any ideas?
> > >
> > > --
> > > Nate Vick
> > > nvick77 at gmail.com
> > > _______________________________________________
> > > Mongrel-users mailing list
> > > Mongrel-users at rubyforge.org
> > > http://rubyforge.org/mailman/listinfo/mongrel-users
> > >
> >
> >
> > _______________________________________________
> > Mongrel-users mailing list
> > Mongrel-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/mongrel-users
> >
>
>
>
> --
> Nate Vick
> nvick77 at gmail.com
>


More information about the Mongrel-users mailing list