[Mongrel] problem with Mongrel and Vista (port 80)

Ilyas Iskakov lists at ruby-forum.com
Sat Feb 9 00:26:01 EST 2008


Hello,

I have problem with Mongrel and Vista, I'm trying to launch mongrel web
server on Vista platform and getting the following error:

** Ruby version is not up-to-date; loading cgi_multipart_eof_fix
** Starting Mongrel listening at 0.0.0.0:80
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/lib/mongrel/tcphack.rb:12:in
`initialize_without_backlog': Bad file descriptor - bind(2)
(Errno::EBADF)
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/lib/mongrel/tcphack.rb:12:in
`initialize'
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/lib/mongrel.rb:560:in
`initialize'
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/lib/mongrel/configurator.rb:128:in
`listener'
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/bin/mongrel_rails:98:in
`cloaker_'
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/lib/mongrel/configurator.rb:51:in
`initialize'
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/bin/mongrel_rails:83:in
`run'
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/lib/mongrel/command.rb:211:in
`run'
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.0-mswin32/bin/mongrel_rails:243
   ... 7 levels...
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in
`require'
  from
E:/Server/Ruby/lib/ruby/gems/1.8/gems/rails-1.2.5/lib/commands/server.rb:39
  from
E:/Server/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
  from E:/ProjectEnviroments/revyr/web/script/server:3

I checked port 80 by 'netstat -a' and this port is free. Mongrel works
with other ports well.
Any one know what is problem?
-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list