[Mongrel] 100% CPU use

Wayne E. Seguin wayneeseguin at gmail.com
Tue Feb 5 10:17:00 EST 2008

On Feb 4, 2008 2:38 PM, Roger Pack <lists at ruby-forum.com> wrote:

> > I needed to restart my mongrel cluster today (updated a Rails
> > controller). And my mongrels didn't really come back up. They bind the
> > port but don't respond to any requests. I can't find any log file that
> > has useful information. These were running fine until I tried the
> > restart. And I have not changed any software versions in a month. (And
> > yes, I tried rolling back the controller change.)
> I had this problem on os x recently--if mongrel has been running
> 'awhile' (i.e. answered a few requests), then i hit ctrl-c on it, it
> uses 100% cpu and never terminates.  Very odd.  Might be a ruby bug.
> Any thoughts?
> (this with mysql, leopard, mongrel 1.1.3).
> thanks.
> -Roger

I also have experienced this with Rails but not Merb so I'm guessing that is
where the issue lie.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20080205/5843b919/attachment.html 

More information about the Mongrel-users mailing list