[Mongrel] Strange Merb error

Ezra Zygmuntowicz ezmobius at gmail.com
Mon Feb 4 16:00:52 EST 2008


Doug-

	Please sudo gem uninstall merb and remove all versions then sudo gem  
install merb again. That should fix it for you. if you have further  
problems then please join #merb in irc.freenode.net and someone will  
help you.

-Ezra

On Feb 4, 2008, at 11:19 AM, Doug Livesey wrote:

> Sorry if this is not the correct place to post this, but I can't  
> really
> find anywhere else!
> I want to learn Merb, but am getting an error when I try to run the
> generated app that goes as follows:
> <ERROR>
> /usr/local/lib/ruby/gems/1.8/gems/merb-0.5.3/lib/merb/version.rb:45:
> warning: already initialized constant RELEASE
> sh: cc: command not found
> /usr/local/lib/ruby/gems/1.8/gems/RubyInline-3.6.6/lib/inline.rb: 
> 406:in
> `build': error executing cc -dynamic -bundle -undefined suppress
> -flat_namespace -Werror  -fno-common -g -O2  -fno-common -pipe
> -fno-common -I /usr/local/lib/ruby/1.8/universal-darwin8.0 -I
> /usr/local/include -o
> "/Users/douglasjohnlivesey/.ruby_inline/Inline_ParseTree_fa12.bundle"
> "/Users/douglasjohnlivesey/.ruby_inline/Inline_ParseTree_fa12.c" :  
> 32512
> (CompilationError)
> Renamed /Users/douglasjohnlivesey/.ruby_inline/Inline_ParseTree_fa12.c
> to /Users/douglasjohnlivesey/.ruby_inline/Inline_ParseTree_fa12.c.bad
> from
> /usr/local/lib/ruby/gems/1.8/gems/RubyInline-3.6.6/lib/inline.rb: 
> 687:in
> `inline'
>  from
> /usr/local/lib/ruby/gems/1.8/gems/ParseTree-2.1.1/lib/parse_tree.rb: 
> 244
>  from
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
> `gem_original_require'
>  from
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
> `require'
>  from
> /usr/local/lib/ruby/gems/1.8/gems/ruby2ruby-1.1.8/lib/ruby2ruby.rb:4
>  from
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
> `gem_original_require'
>  from
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
> `require'
>  from
> /usr/local/lib/ruby/gems/1.8/gems/merb-0.5.3/lib/merb/core_ext/ 
> get_args.rb:2
>   ... 12 levels...
>  from
> /usr/local/lib/ruby/gems/1.8/gems/merb-0.5.3/lib/merb/server.rb:53:in
> `run'
>  from /usr/local/lib/ruby/gems/1.8/gems/merb-0.5.3/bin/merb:4
>  from /usr/local/bin/merb:16:in `load'
>  from /usr/local/bin/merb:16
> </ERROR>
>
> Can anyone offer me any insight into what could be going amiss?
> & sorry again if this is the wrong place.
> Cheers,
>   Doug.
> -- 
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users

- Ezra Zygmuntowicz
-- Founder & Software Architect
-- ezra at engineyard.com
-- EngineYard.com



More information about the Mongrel-users mailing list