[Mongrel] "service mongrel_cluster start" startup fails

David Vrensk david at vrensk.com
Sun Dec 14 18:47:47 EST 2008

On Sat, Dec 13, 2008 at 04:27, Steve Meyer <lists at ruby-forum.com> wrote:

> I did get past this but now the "service mongrel_cluster" fails with the
> following; (i've added the env command to the script)
> service mongrel_cluster start
> TERM=xterm
> PATH=/sbin:/usr/sbin:/bin:/usr/bin
> PWD=/
> LANG=en_US.UTF-8
> _=/bin/env
> /usr/bin/mongrel_cluster_ctl:9:in `require': no such file to load --
> rubygems (LoadError)
>        from /usr/bin/mongrel_cluster_ctl:9
> While /init.d/mongrel_cluster start works and the env info is;
> SHELL=/bin/bash
> TERM=xterm
> USER=sfcapp
> PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
> [...] I have tried adding /usr/local/bin to the path; didn't work

Let me be clear on this... did you add /usr/local/bin to the path in such a
way that 'service mongrel_cluster start' showed PATH=/usr/local/bin:..., but
the cluster did still not start?  Or do you mean that you didn't succeed in
adding /usr/local/bin to the path?  Or something else?

Seeing as three months have gone and we're now in a different era, you could
have a go at setting up apache with mod_rails instead.  The time might be
better spent there; I understand that mod_rails (Fusion passenger) is a nice

Good luck!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/mongrel-users/attachments/20081215/4f1af7a4/attachment.html>

More information about the Mongrel-users mailing list