[Mongrel] custom_require.rb:27:in `gem_original_require': no such

Luis Lavena luislavena at gmail.com
Sun Aug 10 16:23:24 EDT 2008

On Sun, Aug 10, 2008 at 5:11 PM, Luiz Biagi <lists at ruby-forum.com> wrote:
> Will Green wrote:
>> The answer is in the dump from Mongrel startup:
>> `gem_original_require': no such file to load -- win32/service
>> (MissingSourceFile)
>> Try installing the win32-service gem.
> thanks man, I somehow was with the service version 0.0.1, now I
> installed the mswin32 up to date version and I'm receiving a new error:
> => Booting Mongrel (use 'script/server webrick' to force WEBrick)
> => Rails 2.1.0 application starting on
> => Call with -d to detach
> => Ctrl-C to shutdown server
> ** Starting Mongrel listening at
> ** Starting Rails with development environment...
> ** Rails loaded.
> ** Loading any Rails specific GemPlugins
> Exiting
> C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mongrel/config
> urator.rb:372:in `trap': unsupported signal SIGUSR1 (ArgumentError)
>        from

Can you tell us which version of Ruby and RubyGems you have installed?

Looks like is trying to setup signals not support on Windows (SIGUSR1).

Is just me or you've installed mongrel with --platform=mswin32 during
the gem installation? That is plain wrong.

You should install the gem available for your platform, which I think
is mingw32.

Luis Lavena
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams

More information about the Mongrel-users mailing list