[Mongrel] custom_require.rb:27:in `gem_original_require': no such

Luiz Biagi lists at ruby-forum.com
Sun Aug 10 11:11:41 EDT 2008


Will Green wrote:
> The answer is in the dump from Mongrel startup:
> 
> `gem_original_require': no such file to load -- win32/service 
> (MissingSourceFile)
> 
> Try installing the win32-service gem.

thanks man, I somehow was with the service version 0.0.1, now I 
installed the mswin32 up to date version and I'm receiving a new error:

=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.1.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
** Rails loaded.
** Loading any Rails specific GemPlugins
Exiting
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mongrel/config
urator.rb:372:in `trap': unsupported signal SIGUSR1 (ArgumentError)
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/m
ongrel/configurator.rb:372:in `setup_signals'
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/bin/.
./lib/mongrel/rails.rb:174:in `setup_rails_signals'
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/bin/m
ongrel_rails:124:in `cloaker_'
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/m
ongrel/configurator.rb:149:in `call'
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/m
ongrel/configurator.rb:149:in `listener'
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/bin/m
ongrel_rails:99:in `cloaker_'
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/m
ongrel/configurator.rb:50:in `call'
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/m
ongrel/configurator.rb:50:in `initialize'
         ... 14 levels...
        from 
C:/Ruby18/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/commands/server.rb
:39
        from 
C:/Ruby18/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `
gem_original_require'
        from 
C:/Ruby18/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `
require'
        from script/server:3



maybe I should use other version of mongrel?
thanks for the help
-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list