[Mongrel] Date not changing...

Sam sam at three60.com
Thu Apr 24 09:04:29 EDT 2008


Hi,
I had a similar problem, however it wasn't a mongrel issue but  
stupidity on my part.
My date variables were being cached at startup, I had been setting a  
constant to date values.



On Apr 24, 2008, at 5:11 AM, Mattias Bodlund wrote:

> I run Apache/2.2.8 (FreeBSD), mongrel_cluster (1.0.5) and mongrel
> (1.1.3) The app I have issues with is a Rails 1.2.6 app.
>
> In one controller I have a before filter that sets the month, year
> variables to the current month and year if it's not passed in the
> request. The problem that I now have, after changing to the above
> configuration from a lighttpd/fast-cgi), is that the date doesn't get
> updated.
> Lets say I restart mongrel today all is fine but if I let it run
> untill tomorrow I still get the date of yesterday.
>
> As I also mentioned - this is a new behavior I see after I migrated to
> mongrel.
>
> Any ideas?
>
> Cheers
> Mattias
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20080424/51d6e239/attachment.html 


More information about the Mongrel-users mailing list