[Mongrel] fastthread only needed on ruby <=1.8
luislavena at gmail.com
Thu Apr 17 11:18:49 EDT 2008
On Thu, Apr 17, 2008 at 11:31 AM, cdr <_ at whats-your.name> wrote:
> hey.. havent learned gemspec stuff yet, maybe someone who already knows can make the fastthread dep optional?
fastthread is required for ruby version <= 1.8.5, which is most stable
one distributed across servers "in the wild" 1.8.6 with patchlevel
higher than 36 ships with it, but is not widely installed.
Latest code in stable branch make it optional.
> its just kind of annoying, since 'gem install mongrel' always breaks on 1.9, even tho mongrel works fine,
Err, correction: if it compiles doesn't meant it works properly. You
need to run the tests to see what it working and what isn't.
> plus 'gem install mongrel' doesnt even leave a local gem around to manually hack/install
Can you rephrase? Maybe what you need is grab the sources from
repository (svn) and hack yourself the need patches.
> plus there doesnt appear to be a 'gem fetch mongrel'
gem fetch is a RubyGems functionality, not mongrels.
> plus mongrel.org is some domain squatter peddling links to dog supplies
funny, you need to take a lok at this book then:
> so the bottom line is the user has to google for mongrel, dl a tarball, install manually
Use SVN, is not powerful as Git (and all the git lovers) but works.
Patches are welcome
> all cuz of some dep that isnt really a dep
Is just me, my bad english or you don't spell english properly?
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
More information about the Mongrel-users