[Mongrel] mongrel_rails service on windows incompatible with recent ruby builds?

Ralf Vitasek neongrau at gmail.com
Wed Sep 12 02:59:28 EDT 2007

On 9/11/07, Luis Lavena <luislavena at gmail.com> wrote:
> Mmm, you're using win32ole to connect to ADO driver, right?

yes, i even tried hacking the ADO.rb to use SQLNCLI instead of
SQLOLEDB but same behavior with that one. and i'm tied to the ADO
driver since the ODBC driver won't work too many SQL statements don't
work there and hard crash the my rails app due to weird out of memory
errors already when indexing a model with acts_as_ferret.

> Maybe there is a problem due the non-impersonation of the service,
> since by default it will run as SYSTEM, and not the user you're logged
> in.

forgot to mention i tired that already, makes no difference. same
behavior shows up when starting the mongrel_service.exe with the
console switch so i'm pretty sure it's using the same local user as
when starting the app via mongrel_rails directly (which works).

> I'm using 1.8.5 patchlevel 12, since I self-compiled it. I'll give a
> try but doubt will found any problem, mostly since I don't use
> Win32OLE fo my rails projects.

i'm only using it with the sqlserver adapter, nowhere else. what i
haven't tried yet was if the problem also shows when using a different
db adapter. i'm gonna test this today with ODBC and or a test app with

> Maybe you could contact me off the list and give me some insight of
> your setup that I could replicate here.

sure, what do you need to know?
i'm using rails 1.2.3, my DB runs on MS SQL 2005 (Standard).
the problem showed up on Windows XP prof. and Windows Server 2003

i'll do whatever i can to help getting this issue fixed. already took
me 2 weeks to find the cause of my memory leak and finding a fixed
version (sadly ruby-lang.org is still offering the old unfixed
versions on their download page).


More information about the Mongrel-users mailing list