[Mongrel] problems with 'localization simplified'

Luis Lavena luislavena at gmail.com
Sat Oct 27 14:58:10 EDT 2007


On 10/27/07, Luca Reghellin <lists at ruby-forum.com> wrote:
> I'm sorry I was upgrading the gems while you're writing. I've just
> upgraded rails to 1.2.5 too. Now, if I run rails -v, I've got this error
> :(
>
> /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:367:in
> `report_activate_error': RubyGem version error: activesupport(1.4.1 not
> = 1.4.4) (Gem::LoadError)

That seems to be a issue with the versions of activesupport and rails installed.

could you list the gems you have?

gem list rails
gem list activesupport
gem deps rails -v '1.2.5'

The last command should list you what gems of activesupport,
actionpack and activerecord is using, but I guess all is related to
that.

Also, did you updated the config/environment.rb to match the new
installed gems *prior* doing the rake rails:update in your
application?

(That is documented in the Ruby on Rails weblog about the upgrade procedure.

-- 
Luis Lavena
Multimedia systems
-
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi


More information about the Mongrel-users mailing list