[Mongrel] mongrel_rails not starting

Luis Lavena luislavena at gmail.com
Thu Oct 11 19:33:30 EDT 2007

On 10/11/07, Greg Willits <lists at ruby-forum.com> wrote:
> os x 10.4.10
> used gem to install mongrel 1.0.1. seemed to go w/o errors.
> "mongrel_rails start -d" spits out this error
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/http11.bundle:
> Failed to load
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/http11.bundle
> (LoadError)
>         from
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
> `require'
>         from
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:11

It seems there is no bundle (compiled extension) for http11, which is
need by Mongrel.

> installed again with --include-dependencies
> still getting same error.
> lost. need a flashlight.

Do you have everything to compile   ruby extensions in place? Which
version of ruby are you using? the broken one that came with OSX or
compiled by hand?

What's the output of gem install mongrel? You should see the details
about "building native extensions"...

Luis Lavena
Multimedia systems
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi

More information about the Mongrel-users mailing list