[Mongrel] Error with Mongrel_cluster

Sid News sid.webnews at gmail.com
Mon Oct 1 16:48:55 EDT 2007


Guys,
Thanks for the replies.
This is how my .bashrc looks like

-----begin .bashrc ..............
>more .bashrc
#/etc/profile: system-wide .profile file for the Bourne shell (sh(1))
# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
ORACLE_HOME=/usr/lib/oracle/10.2.0.3/client
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games:/usr/lib/oracle/10.2.0.3/client/bin
LD_LIBRARY_PATH=/usr/lib/oracle/10.2.0.3/client/lib
export ORACLE_HOME
export LD_LIBRARY_PATH
if [ "$PS1" ]; then
  if [ "$BASH" ]; then
    PS1='>'
  fi
fi

umask 022
--------------------------------------------------
I follow these instructions to setup my mongrel_cluster
http://mongrel.rubyforge.org/docs/mongrel_cluster.html

The mongrel_cluster and mongrel_rails both worked fine, but my supervisor
installed oci8 or oracle and then when i try to start mongrel_rails it would
give me the same error. Googling it led me to add the environment variables
$ORACLE_HOME and $LD_LIBRARY_PATH , after that mongrel_rails works.
But mongrel_cluster is still broken and I'm not sure what more do I need to
do to get it back running. I must be missing something about
mongrel_cluster.

My setup is Ubuntu 6.06.1 LTS , nginx (webserver) ruby 1.8.4
Thanks.


On 10/1/07, Wayne E. Seguin <wayneeseguin at gmail.com> wrote:
>
>
>
> On 10/1/07, Wayne E. Seguin <wayneeseguin at gmail.com> wrote:
> >
> > On 10/1/07, Sid Jay <sid.webnews at gmail.com > wrote:
> > >
> > >  Hi Guys,
> > > I'm getting this error with mongrel_cluster. I am able to start
> > > mongrel through mongrel_rails start but the cluster is not working.
> > >  Initially mongrel_rails wouldn't work but after I added $ORACLE_HOME and
> > > $PD_LIBRARY_PATH variables it worked but mongrel_cluster isn't working
> > > still. The mongrel log file looks like below.
> > > Any help is appreciated.
> > > Thanks.
> > >
> >
>
> Also, are you also making sure that you use "export " when assigning the
> $ORACLE_HOME and $PD_LIBRARY_PATH variables? (assuming you're using bash)
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20071001/804131c3/attachment.html 


More information about the Mongrel-users mailing list