[Mongrel] Mongrel install crash on win32

Luis Lavena luislavena at gmail.com
Wed Nov 28 11:16:05 EST 2007

On Nov 28, 2007 5:38 AM, Jesper Rønn-jensen <lists at ruby-forum.com> wrote:
> Here is the proper end of the story:
> I tried to reinstall as described above, but 0.9.5 did not uninstall.
> End of story was that I had to:
> * uninstall C:\ruby
> * reinstall gems
> It took a bit longer. But finally worked.

Jesper, please excuse I couldn't answer you back yesterday, was a
nightmare here at the office (the redundant power supply of one server
crashed, all the 3!) So took us a lot of hard work to put it back

Regarding your problem, you should have:

Downloaded rubygems-0.9.4.zip from rubyforge page [1]

Unpacked into any clean folder,

run: ruby setup.rb install

that should have overwrite your 0.9.5 installation.

If that didn't work as expected, you an also remove
lib/ruby/site_ruby/1.8 the files and folders for rubygems:

ubygems.rb rubygems.rb and rubygems folder.

Then install 0.9.4 again as described above.

Luis Lavena
Multimedia systems
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi

More information about the Mongrel-users mailing list