[Mongrel] Fresh install on Debian Etch - Mongrel immediately hangs

Andreas Wolff rubyphunk at googlemail.com
Fri Nov 23 12:51:36 EST 2007


I had the same error a few days ago. Installing ruby 1.8.6 (from source)
fixed my problem. However: You may need to install gem cgi_multipart_eof_fix

bye
rubyphunk


On 11/23/07, Benny Beesnus <lists at ruby-forum.com> wrote:
>
> Hi,
>
> I just did a clean install of
>
> Ruby 1.8.5
> Rubygems 0.9.0
>
> and the Mongrel and Mongrel_Cluster gems.
>
> I used only the Debian Etch package manager, nothing compiled myself.
>
> Now, on a testapp when I do a script/server, I get the:
>
> ** Ruby version is not up-to-date; loading cgi_multipart_eof_fix
>
> warning. But it's not serving my app. Ruby is immediately on 100% CPU
> load (and 0.7% memory) and stays there.
>
> When I press CTRL-C on the console I started the server from, I get
>
> => Booting Mongrel (use 'script/server webrick' to force WEBrick)
> => Rails application starting on http://0.0.0.0:3000
> => Call with -d to detach
> => Ctrl-C to shutdown server
>
> but still, nothing is served and Ruby process at 100% CPU.
>
> Trying to do a mongrel_rails -B to debug it produces no debug log. The
> hang is very immediate.
>
> Nothing in any logs.
>
> Please help me!
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20071123/0154a7c4/attachment-0001.html 


More information about the Mongrel-users mailing list