[Mongrel] mongrel and fastthread on ruby 1.9?

Todd Fisher todd.fisher at gmail.com
Sun Nov 18 16:51:16 EST 2007


Here's an initial patch to support ruby 1.9


On Nov 18, 2007 12:56 PM, Luis Lavena <luislavena at gmail.com> wrote:
> On Nov 18, 2007 3:12 AM, Stephen Bannasch
> <stephen.bannasch at deanbrook.org> wrote:
> > Is anybody testing mongrel on ruby 1.9. I just tried installing
> > mongrel on trunk 1.9 and trunk rubygems and got this error compiling
> > fastthread:
> >
>
> Fastthread corrected problems on Ruby 1.8 implementation of array,
> mutex and synchronize.
>
> These corrections where merged to trunk and are available under
> --disable-fastthread option of configure.
>
> Also, ruby 1.8.6 ships with these changes, so dependency of fastthread
> is only required for ruby < 1.8.6
>
> --
> Luis Lavena
> Multimedia systems
> -
> Leaders are made, they are not born. They are made by hard effort,
> which is the price which all of us must pay to achieve any goal that
> is worthwhile.
> Vince Lombardi
> _______________________________________________
>
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ruby19.patch
Type: application/octet-stream
Size: 2353 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/mongrel-users/attachments/20071118/4c070eca/attachment.obj 


More information about the Mongrel-users mailing list