[Mongrel] Mongrel 1.0.2 on Ubuntu Feisty

Gunnar Wolf gwolf at gwolf.org
Mon Nov 5 14:11:00 EST 2007


Andrei Maxim dijo [Sun, Oct 28, 2007 at 01:18:22AM +0200]:
> Hi everybody,
> 
> I've been trying to setup a Ruby on Rails application on a Ubuntu Feisty
> machine and I've spent a lot of time trying to figure out why Nginx and
> mongrel_cluster weren't working. The setup was correct (based on some
> tutorials found on the internet), but there weren't any pid files for the
> mongrels started.
> 
> In case anybody else has experienced the same problem, it seems that `gem
> install mongrel` will install version 1.0.2 (which is rather strange since
> there isn't such a version on Rubyforge, it's either 1.0.1 or 1.0.3) which
> is broken. I found a typo in configurator.rb on line 63 where instead of
> target_gid it was just target_id. Forcing version 1.0.3 fixes the problem.
> 
> However, I'm wondering why v. 1.0.2 gets installed. Any ideas?

Hi,

In Debian-like systems, I suggest you to install the 'mongrel'
package, even if I risk starting a new flamefest in here ;-) Having
different package management systems in the same OS (in this case,
.deb packages and Ruby Gems) can lead to anger and pain. And, as we
all know, that's just the first step down towards the Dark Side. 

I'm unsure whether Ubuntu Feisty includes a packaged Mongrel - I'm
currently co-maintainer for Mongrel in Debian, and it's at 1.0.1
(although I plan on upgrading today/tomorrow). 

Greetings,

-- 
Gunnar Wolf - gwolf at gwolf.org - (+52-55)5623-0154 / 1451-2244
PGP key 1024D/8BB527AF 2001-10-23
Fingerprint: 0C79 D2D1 2C4E 9CE4 5973  F800 D80E F35A 8BB5 27AF


More information about the Mongrel-users mailing list