[Mongrel] mongrel not finding correct ruby path

Greg Clarke gregbclarke at gmail.com
Mon Nov 5 06:19:05 EST 2007

Have you installed rubygems in your new ruby installation?

See here, http://www.rubyonrails.org/down, where the first step after
installing ruby is to install rubygems.

This is where rubygems sits in my 1.8.6 ruby install:

So, maybe you need to check your $PATH, check ruby -v , then install rubygems.


On 11/5/07, Barun Singh <barunio at gmail.com> wrote:
> hello all,
> i have been trying to figure this out for the last few hours, and after
> seemingly exhausting all the google search results, i figured i would try
> this mailing list...
> i just updated the ruby version on my ubuntu dapper drake box to the most
> recent version.  i installed it into /usr/local/bin
> problematically, the previous installation was in /usr/bin
> mongrel still complains that:
> "Ruby version is not up-to-date; loading cgi_multipart_eof_fix"
> from looking at /usr/bin/mongrel_rails, i can see that the first line of the
> file is:
> #!/usr/bin/ruby1.8
> which is the old version of ruby (1.8.4)
> I tried changing the shebang to the correct path of
> #!/usr/local/bin/ruby
> but then it gave me an error that it couldn't find "rubygems"
> every other method i could think of to have it point to the right place
> (such as moving the new ruby binary into the /usr/bin directory along with
> the rdoc, ri, etc. files) all resulted in the same problem with rubygems not
> being found.
> does anyone have any idea how i can get mongrel to see the correct, updated
> version of ruby??
> thanks...
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users

More information about the Mongrel-users mailing list