[Mongrel] No return status from mongrel upload progress (and thus no updates on the bar)

John Lauck john-subscribed at recaffeinated.com
Fri May 18 10:05:18 EDT 2007


Craig,

I have no experience with Boxroom, but I did just recently get the Mongrel
Upload Progress working using the instructions on mongrel's site.

I'm developing locally on OS X, haven't tested moving it to my Cent OS
production environment yet.

Anyway, are you running the upload.rb mentioned on the site?  I forgot to
execute that script along with mongrel a couple times and couldn't figure
out what was wrong.  I also changed all the 0.0.0.0 IPs  serving drb to
127.0.0.1 and it worked at that point.  It was hard to gauge the upload
progress because I only tested it on my local LAN so all uploads were at
100% within a second.  However, it seemed to be working fine.


John

On 5/17/07, Craig Box <craig at itpartners.co.nz> wrote:
>
> Hi all,
>
> I'm using Boxroom (http://boxroom.rubyforge.org/) and trying to get
> upload progress working.  I've also been testing the sample code at
> http://itblog.mcgeecorp.com/2007/5/15/mongrel-upload-progress-demo/.
>
> I run a Mongrel cluster, and so am using drb (as per
> http://mongrel.rubyforge.org/docs/upload_progress.html).  Starting up
> rails, I get lots of useful-sounding output:
>
> ** Starting Mongrel listening at 0.0.0.0:3000
> ** Loading script/../config/../config/mongrel_upload_progress.conf
> external config script
>
> The bar doesn't draw updates - if I connect with irb (as per the
> upload_progress page)
>
> irb(main):001:0> uploads = get_status
> => #<DRb::DRbObject:0xb7d1ef04 @ref=nil, @uri="druby://0.0.0.0:2999">
> irb(main):002:0> uploads.list
> => []
>
> Nice regular output in my development.log:
>
> Processing UploadsController#upload_progress (for 127.0.0.1 at
> 2007-05-18 15:20:29) [POST]
>   Parameters: {"action"=>"upload_progress", "controller"=>"uploads",
> "upload_id"=>"aff07334-04ee-11dc-bd4b-000d608392b8"}
> Completed in 0.00966 (103 reqs/sec) | Rendering: 0.00848 (87%) | 200 OK
> [http://localhost/uploads/upload_progress?upload_id=aff07334-04ee-11dc-b
> d4b-000d608392b8]
>
>
> Processing UploadsController#upload_progress (for 127.0.0.1 at
> 2007-05-18 15:21:11) [POST]
>   Parameters: {"action"=>"upload_progress", "controller"=>"uploads",
> "upload_id"=>"aff07334-04ee-11dc-bd4b-000d608392b8"}
> Completed in 0.00909 (109 reqs/sec) | Rendering: 0.00800 (88%) | 200 OK
> [http://localhost/uploads/upload_progress?upload_id=aff07334-04ee-11dc-b
> d4b-000d608392b8]
>
> status is always nil.  It sounds like exactly the same problem as this
> person is having: http://www.ruby-forum.com/topic/102380
>
>
> The entire setup is running on Ubuntu Dapper, with mongrel 1.0.1,
> cluster/upload_progress 0.2.1, rails 1.2.3 and rubygems 0.9.3.
>
> Any ideas?  Should I (as per
> http://rubyforge.org/pipermail/mongrel-users/2006-November/002237.html)
> look at running something other than Mongrel for accepting uploads?
>
>
> Regards,
> Craig
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070518/a1701614/attachment.html 


More information about the Mongrel-users mailing list