[Mongrel] mongrel_cluster 1.0.1.1 does not create /var/run/mongrel_cluster

Joey Geiger jgeiger at gmail.com
Wed May 9 13:06:37 EDT 2007


I had an issue with the /var/run/mongrel_cluster issue as I'm not
starting the cluster via the init.d script anymore. I'm using monit to
start up each of the mongrels by themselves. Due to that, I need to
create that directory via it's own init.d script so it exists before
monit tries to start them up...

kinda hacky, but it's working for me now.


On 5/9/07, Bradley Taylor <bradley at railsmachine.com> wrote:
> The new init.d script already does this. Look in
> resources/mongrel_cluster in the gem directory.
>
> Bradley
>
> Joey Geiger wrote:
> > I created a startup script that just creates the
> > /var/run/mongrel_cluster on boot, since it's removed every time you
> > restart.
> >
> >
> > On 5/8/07, Ehud Rosenberg <ehudros at gmail.com> wrote:
> >> Hi everyone,
> >> I am going crazy over here! :)
> >> I just want to be able to use --clean with my mongrel_rails
> >> cluster::start command.
> >> I've upgraded to mongrel_cluster 1.0.1.1 and mongrel_rails 1.0.1.
> >> my config file is in /etc/mongrel_rails/config.yml
> >> and contains:
> >> ---
> >> log_file: log/mongrel.log
> >> port: 8000
> >> pid_file: /var/run/mongrel_cluster/mongrel.pid
> >> servers: 2
> >> address: 127.0.0.1
> >> environment: production
> >>
> >> in the following post it says the init.rb script from mongrel_cluster
> >> should create the var/run directory itself, but it does not seem to do
> >> so ( I get the message:
> >> !!! Path to log file not valid: log/mongrel.8001.log
> >> mongrel::start reported an error. Use mongrel_rails mongrel::start -h
> >> to get help)
> >>
> >> Also, when I manually set the pid file dir to what it used to be (the
> >> log dir of my app)
> >> it does not clean it up and still give the old message that a PID
> >> already exists - i'm not sure if that's because it's not in /var/run
> >> as I have seen different comments on this.
> >>
> >> Any help would be appreciated...
> >>
> >> Thanks!
> >> Ehud.
> >>
> >> PS - I have also tried running mongrel_rails cluster::configure -C /
> >> etc/mongrel_rails/config.yml again but all it did was overwrite my
> >> file...
> >>
> >>
> >> _______________________________________________
> >> Mongrel-users mailing list
> >> Mongrel-users at rubyforge.org
> >> http://rubyforge.org/mailman/listinfo/mongrel-users
> >>
> > _______________________________________________
> > Mongrel-users mailing list
> > Mongrel-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/mongrel-users
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>


More information about the Mongrel-users mailing list