[Mongrel] Problems with mongrel_cluster 1.0.1.1 on FreeBSD

Matte Edens matte at ruckuswireless.com
Fri May 4 14:26:13 EDT 2007


I too am running mongrel on 6.1 but I have a few on 4.x as well.  I 
experienced problems with stopping mongrels UNTIL I switched the pidfile 
location in the config file to point to

/var/tmp/[site].pid

If you are using a relative path to your pid files in the config file, 
as I was when I was having problems, it wouldn't properly stop.  I'm not 
sure of your exact circumstances but you might try switching the pidfile 
location.  This made ALL the difference.  I have NO problems with 
processes that won't stop.

Using the /var/tmp directory is regarded as "best practice".  This is, I 
believe, mentioned in the release announcement for the 1.0.1.1 
pre-release.  Search the archives and you should find it.

matte

Pat Maddox wrote:
> On 5/4/07, Pat Maddox <pergesu at gmail.com> wrote:
>   
>> I'm running FreeBSD 6.1 and installed the 1.0.1.1 mongrel_cluster
>> prerelease.  I had a problem with the mongrels not stopping, and it
>> turns out it's because ps is reporting my processes as just
>> [ruby18]
>>
>> instead of someting more like "mongrel_rails start -d ......."
>>
>> Not sure why it's doing that, but it is.  Any ideas?
>>
>> For the time being I just changed line 165 of init.rb to read
>> pid = ps_output =~ /mongrel_rails|ruby18/ ? pid : nil
>>
>> and that's working fine.
>>
>> Pat
>>
>>     
>
> I've got two sets of mongrels running now, one running a staging
> environment and the other production.
>
> [twist at jack ~/twist/shared/log]$ ps ax | grep ruby
> 88908  ??  S      0:01.96 [ruby18]
> 88911  ??  S      0:02.15 [ruby18]
> 88914  ??  S      0:02.14 [ruby18]
> 89021  ??  S      0:01.95 /usr/local/bin/ruby18 /bin/mongrel_rails
> start -d -e production -c
> 89026  ??  S      0:01.95 /usr/local/bin/ruby18 /bin/mongrel_rails
> start -d -e production -c
> 89029  ??  S      0:01.95 /usr/local/bin/ruby18 /bin/mongrel_rails
> start -d -e production -c
>
> The [ruby18] processes are all staging mongrels.  Any clue as to why
> they wouldn't show the full command?
>
> Pat
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>   

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070504/9753ccbc/attachment.html 


More information about the Mongrel-users mailing list