[Mongrel] Error with Ruby 1.8.6

Pete DeLaurentis pete at nextengine.com
Sat Mar 31 21:17:53 EDT 2007


Hi,

I just upgraded to Ruby 1.8.6 on my Mac development machine and  
here's what I'm seeing when I try to run mongrel (I have the latest  
version of mongrel + fastthread installed).  It seems to be an OS/X  
thing, because this same combo works fine on our Linux server.

Here's the error, have you guys seen anything like this?:

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
uuid: Found an existing UUID state file: /nextweb/code/trunk/uuid.state
dyld: NSLinkModule() error
dyld: Symbol not found: _rl_filename_completion_function
   Referenced from: /usr/local/lib/ruby/1.8/i686-darwin8.9.1/ 
readline.bundle
   Expected in: flat namespace

script/mdev: line 1: 16097 Trace/BPT trap          mongrel_rails  
start -p 3000 -t 1

Thanks,
Pete


More information about the Mongrel-users mailing list