[Mongrel] [ANN] Another mongrel_cluster prerelease 1.0.1.1

Carl Lerche carl.lerche at gmail.com
Tue Mar 27 12:59:44 EDT 2007


For me, I fixed this problem by adding the following on line 79 of init.rb:

Dir.chdir(@options["cwd"]) if @options["cwd"]

-carl

On 3/27/07, Carl Lerche <carl.lerche at gmail.com> wrote:
> Hello,
>
> I'm not sure if it's a slight bug with mongrel_cluster or me, but I'm
> having some trouble running mongrel cluster with --clean in different
> directories than the root of the rails app.
>
> It doesn't look like mongrel_cluster changes the working directory
> anywhere (based off of the config file, but just passes the working
> directory on to mongrel_rails. This is fine, except when it tries to
> check the pid files. Does this make sense?
>
> thanks,
> -carl
>
> On 3/27/07, Bradley Taylor <bradley at railsmachine.com> wrote:
> > Hi Michele:
> >
> > Thanks for the freebsd report. I think there is a way for you to mount
> > /proc to support linux process environment emulation.
> >
> > I'll also gladly accept a patch from anyone for 'ps' syntax that cause
> > this warning.
> >
> > I think we'll release it as is today and due a quick patch if someone
> > provides a fix.
> >
> > Regards,
> > Bradley Taylor
> > http://railsmachine.com
> >
> > Michele wrote:
> > > Bradley,
> > >
> > > It seems to work on FreeBSD (I had to delete all gems before it
> > > actually worked), even though I still get this:
> > >
> > > Checking all mongrel_clusters...
> > > mongrel_rails cluster::status -C config.yml
> > > ps: Process environment requires procfs(5)
> > > ps: Process environment requires procfs(5)
> > > ps: Process environment requires procfs(5)
> > > ps: Process environment requires procfs(5)
> > > ps: Process environment requires procfs(5)
> > >
> > > Best,
> > > - MF
> > >
> > > --
> > > Michele Finotto
> > > http://finotto.org/
> > > http://16bugs.com/
> > > http://pagety.com/
> > >
> > >
> > > On Mar 20, 2007, at 15:53 , Bradley Taylor wrote:
> > >
> > >> Hi all...
> > >>
> > >> Hopefully this is the last prelease. If people on non-linux systems
> > >> could post back any problems with cluster::status, I'd appreciate it.
> > >>
> > >> Install with:
> > >> gem install mongrel_cluster --source http://mongrel.rubyforge.org/
> > >> releases/
> > >>
> > >> Note: This is only an update to mongrel_cluster and not Mongrel or
> > >> other
> > >> gems.
> > >>
> > >> Details about what's new (if you missed the first prerelease):
> > >> http://blog.railsmachine.com/2007/2/26/mongrel_cluster-
> > >> prerelease-1-0-1-1
> > >>
> > >> Thanks,
> > >> Bradley Taylor
> > >> http://railsmachine.com
> > >
> > > _______________________________________________
> > > Mongrel-users mailing list
> > > Mongrel-users at rubyforge.org
> > > http://rubyforge.org/mailman/listinfo/mongrel-users
> >
> > _______________________________________________
> > Mongrel-users mailing list
> > Mongrel-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/mongrel-users
> >
>
>
> --
> EPA Rating: 3000 Lines of Code / Gallon (of coffee)
>


-- 
EPA Rating: 3000 Lines of Code / Gallon (of coffee)


More information about the Mongrel-users mailing list