[Mongrel] [ANN] fastthread 1.0

hemant gethemant at gmail.com
Tue Mar 20 08:15:37 EDT 2007


On 3/20/07, Wayne E. Seguin <wayneeseguin at gmail.com> wrote:
>
> On Mar 20, 2007, at 00:59 , MenTaLguY wrote:
> > fastthread is a Ruby extension which re-implements the primitives in
> > Ruby's thread.rb in C.  It was merged into 1.8.6, replacing the old
> > thread.rb implementation, but the version that was merged had a couple
> > serious bugs.
>
> Mental,
>
> What might these serious bugs be?
>
> Thanks,
>
>    ~Wayne
>

With a freshly created plain vanilla rails app with no
code/controller/model added, when i attempt to start it, i get:

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:477:in
`const_missing': uninitialized constant
ActiveRecord::ConnectionAdapters::TwelveByteKey::Mutex (NameError)
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connection_adapters/frontbase_adapter.rb:55
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in
`require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:342:in
`new_constants_in'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in
`require'
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record.rb:81
        from /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record.rb:80
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
         ... 11 levels...
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:83:in
`run'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/command.rb:211:in
`run'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:243
        from /usr/bin/mongrel_rails:18


This is when, I have ruby 1.8.6 installed and fastthread gem version
1.0 is also installed. Any ideas why is this?


More information about the Mongrel-users mailing list