[Mongrel] Mongrel Hangs After Idle Period

Eric Dean eric at maverixsystems.com
Sat Mar 10 12:37:28 EST 2007

I had posted a thread couple of weeks ago whereby mongrel just mysteriously
stops interacting with my application after an idle period...usually less
than 8 hours.  
I had hoped this would go away after a few upgrades but to know avail.
Interestingly, the process does not die...it still accepts HTTP requests but
does not respond...just sits there deaf.  I do a cluster::stop and start and
we're back in action.
There is nothing at the tail of mongrel_log..and when I make new
connections..nothing gets appended
The answers to the previously asked questions are as follows:
1) We do not rotate logs (yet) so we don't use ruby to rotate
2) ruby script/about
About your application's environment
Ruby version                 1.8.5 (i686-linux)
RubyGems version             0.9.1
Rails version                1.2.0
Active Record version        1.14.4
Action Pack version          1.12.5
Action Web Service version   1.1.6
Action Mailer version        1.2.5
Active Support version       1.3.1
Edge Rails revision          175
Application root             /home/webapp/visualcareers_3_7
Environment                  development
Database adapter             mysql
Database schema version      44
3) cat config/database.yml
  adapter: mysql
  database: server_development
  username: ******
  password: ******
  host: my.server.com
  adapter: mysql
  database: server_test
  username: ******
  password: ******
  host: localhost
  adapter: mysql
  database: server_production
  username: ******
  password: ******
  host: localhost
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070310/cf5da20e/attachment.html 

More information about the Mongrel-users mailing list