[Mongrel] FreeBSD 6.1 mongrel_cluster and procfs message

Bradley Taylor bradley at railsmachine.com
Sun Mar 4 13:19:55 EST 2007


This 'ps' syntax is really annoying. If my score-keeping is correct:

Linux and FreeBSD seem to support both 'args' and 'command'.
Darwin/MacOSX doesn't support 'args'.
Solaris doesn't support 'command'.

I guess I need to resort to platform checks. I was hoping to avoid this 
by using the 'standard format specifiers'. The great thing about 
standards is that there are so many to choose from.

Bradley

Patrick Berry wrote:
> On 3/4/07, Jamie Orchard-Hays <jamie at dangosaur.us> wrote:
>> Kirk, I followed the instructions on the following link, but no love.
>> I seem to have mounted fine, but I'm getting the same error reported
>> back from mongrel_cluster_ctl.
>>
>> http://os.newsforge.com/os/06/03/22/1531252.shtml?tid=8&tid=2
>>
>> Jamie
>>
> 
> It is a ps command problem.  I ran into the same issue when testing
> locally on OS X.  Options are to wait for another *pre-release* of
> mongrel_cluster or making the following mod to line 164 of init.rb in
> the check_process method:
> 
> old:   ps_output = `ps -o args= -p #{pid}`
> new: ps_output = `ps -o command= -p #{pid}`
> 
> Pat
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users



More information about the Mongrel-users mailing list