[Mongrel] FreeBSD 6.1 mongrel_cluster and procfs message

Jamie Orchard-Hays jamie at dangosaur.us
Sun Mar 4 11:17:32 EST 2007


Kirk, I followed the instructions on the following link, but no love.  
I seem to have mounted fine, but I'm getting the same error reported  
back from mongrel_cluster_ctl.

http://os.newsforge.com/os/06/03/22/1531252.shtml?tid=8&tid=2

Jamie

On Mar 4, 2007, at 10:44 AM, Jamie Orchard-Hays wrote:

> Thanks. I'd found a bit about that after I sent the message. Things
> worked fine with 0.2.1--except that mongrel_cluster's restart did not
> work properly if nothing was running, which cost me an hour a day
> earlier before I realized what was wrong. That's was my motivation to
> upgrade.
>
> If you have any simple instructions about how to get this working on
> FreeBSD, I'll be very grateful!
>
> Jamie
>
> On Mar 4, 2007, at 4:17 AM, Jonathan Weiss wrote:
>
>> The message means that you need the procfs virtual filesystem  
>> mounted.
>> Normally you do not need this under FreeBSD.
>>
>> I use Mongrel 1.0.1 + mongrel_cluster (0.2.1) on FreeBSD 6.2
>> without any
>> glitches, so maybe mongrel_cluster 1.0.1.1 introduces some
>> Linux-specific ps syntax that requires procfs.
>>
>> I will try to upgrade my mongrel_cluster version and see if I get the
>> same message.
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users



More information about the Mongrel-users mailing list