[Mongrel] [ANN] You Will All Die In 1 Week (Mongrel To Require 1.8.6)

Zed A. Shaw zedshaw at zedshaw.com
Thu Jun 28 16:24:39 EDT 2007


On Thu, 28 Jun 2007 13:13:52 -0700
Ezra Zygmuntowicz <ezmobius at gmail.com> wrote:

> 
> On Jun 28, 2007, at 1:02 PM, Zed A. Shaw wrote:
> 
> > Hopefully that gets everyone's attention.
> >
> > Evan Weaver has whined enough to make me do a release to change the  
> > requirements on the Mongrel gem so that it doesn't need the  
> > cgi_multipart_eof_fix anymore.

> 	The only problem with requiring ruby 1.8.6 is that there is no  
> production worthy release of 1.8.6 yet. Even the latest patch level  
> release from last week has bugs in the new Thread code that are  
> resolved in svn but not in any public release yet.

Awesome!  That's the exact answer I need from someone who's actually doing real stuff.  

So, 1.8.6 isn't viable, that means this cgi fix needs a more official standing so that it's maintained.  Evan's doing it in his project but maybe a more official ruby-core-is-lazy-hot-fixes project?

Thanks a ton Ezra.

-- 
Zed A. Shaw
- Hate: http://savingtheinternetwithhate.com/
- Good: http://www.zedshaw.com/
- Evil: http://yearofevil.com/


More information about the Mongrel-users mailing list