[Mongrel] [ANN] You Will All Die In 1 Week (Mongrel To Require 1.8.6)

Jonathan Weiss jw at innerewut.de
Thu Jun 28 16:12:03 EDT 2007

 > 2) Tell me if
> doing the upgrade will make your entire world implode.  

This will make my world implode as I'm dependent on Ruby 1.8.5. Ruby 
1.8.6 has some bugs that effect most of my projects.

With Ruby 1.8.6 you have a lot of problems with continuous integration 
tools as Ruby 1.8.6 returns a wrong return code on test runs with 
test/unit. Further 1.8.6 changes some Date functions that break my code. 
Some of this is fixed in the trunk but AFAIK not all in the latest patch 

So, please do not make Mongrel dependent on Ruby 1.8.6.

> Thanks for your help folks.


Jonathan Weiss

More information about the Mongrel-users mailing list