[Mongrel] Q on cgi_multipart_eol_fix preqequisite for Mongrel on Win2K

Luis Lavena luislavena at gmail.com
Wed Jun 27 13:24:32 EDT 2007


On 6/27/07, Vasudev Ram <vasudevram at gmail.com> wrote:
>
> Hi list,
>
> I downloaded and tried to install Mongrel (latest stable version) from the
> -win32 gem. Platform is Win2K.
> It said it needed daemons so got and installed that.

Wait a second:

if It asked about daemons, is not win32 gem... is the ruby version.

> Then it said it needed
> cgi_multipart_eol_fix (I think that was the name, not at my machine now, can
> confirm later and repost if needed). Googled for that but couldn't find it.

cgi_multipart_eol_fix is available via rubygems too, are you doing a
manual install?

If so, then I will suggest use --ignore-dependencies in 'gem install':

gem install "gem-name.gem" --ignore-dependencies

> (Don't have net connectivitity for a while - problems with brain-dead ISPs
> where I live - so can't do remote gem installs with --include-dependencies-
> have to download the gem and its prerequisites manually and install them).
> Any ideas?
>

Sorry, wrote the text before read the whole mail :-P

mongrel-1.0.1-win32.gem
cgi_multipart_eol_fix-0.2.1.gem (guess thats the version).
mongrel_service-0.3.2-win32.gem (if you plan run mongrel as service).
win32-service-0.5.2-win32.gem (if you need mongrel_service).

Guess thats everything.

-- 
Luis Lavena
Multimedia systems
-
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi


More information about the Mongrel-users mailing list