[Mongrel] disappearing .pid files

Dave C dklamath at hotmail.com
Fri Jun 22 04:04:58 EDT 2007


I ran into the same problem last week, however it was on a single instance 
of mongrel on a shared host through webfaction, not a cluster like you are 
on most likely on a dedicated server to boot.

Our problem turned out to be an issue of having another rails application 
installed (even though it was not supposed to be) and when the server got 
rebooted the script started that rails app by default.

Hope something here helps trigger some ideas for you.

Dave

----Original Message Follows----
From: jeremy*pinnix <jpinnix.alt at gmail.com>
Reply-To: mongrel-users at rubyforge.org
To: Mongrel-users at rubyforge.org
Subject: [Mongrel] disappearing .pid files
Date: Thu, 21 Jun 2007 17:26:40 -0500
MIME-Version: 1.0
Received: from rubyforge.org ([205.234.109.18]) by 
bay0-mc11-f1.bay0.hotmail.com with Microsoft SMTPSVC(6.0.3790.2668); Thu, 21 
Jun 2007 15:27:35 -0700
Received: from rubyforge.org (rubyforge.org [127.0.0.1])by rubyforge.org 
(Postfix) with ESMTP id 1523A5240C0D;Thu, 21 Jun 2007 18:27:35 -0400 (EDT)
Received: from wa-out-1112.google.com (wa-out-1112.google.com 
[209.85.146.181])by rubyforge.org (Postfix) with ESMTP id 7F19A5240B21for 
<Mongrel-users at rubyforge.org>; Thu, 21 Jun 2007 18:26:41 -0400 (EDT)
Received: by wa-out-1112.google.com with SMTP id l24so523384waffor 
<Mongrel-users at rubyforge.org>; Thu, 21 Jun 2007 15:26:40 -0700 (PDT)
Received: by 10.114.95.1 with SMTP id s1mr2201865wab.1182464800684;Thu, 21 
Jun 2007 15:26:40 -0700 (PDT)
Received: by 10.114.157.10 with HTTP; Thu, 21 Jun 2007 15:26:40 -0700 (PDT)
X-Message-Info: 
LsUYwwHHNt0EcBwwqClCjkgKA+k2y79KE8t6zc82v/ze+pqzz6mnvbFt46lFXGqf
X-Original-To: Mongrel-users at rubyforge.org
Delivered-To: Mongrel-users at rubyforge.org
X-BeenThere: mongrel-users at rubyforge.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: <mongrel-users.rubyforge.org>
List-Unsubscribe: 
<http://rubyforge.org/mailman/listinfo/mongrel-users>,<mailto:mongrel-users-request at rubyforge.org?subject=unsubscribe>
List-Archive: <http://rubyforge.org/pipermail/mongrel-users>
List-Post: <mailto:mongrel-users at rubyforge.org>
List-Help: <mailto:mongrel-users-request at rubyforge.org?subject=help>
List-Subscribe: 
<http://rubyforge.org/mailman/listinfo/mongrel-users>,<mailto:mongrel-users-request at rubyforge.org?subject=subscribe>
Errors-To: mongrel-users-bounces at rubyforge.org
Return-Path: mongrel-users-bounces at rubyforge.org
X-OriginalArrivalTime: 21 Jun 2007 22:27:35.0732 (UTC) 
FILETIME=[5E18D740:01C7B453]

Hello,

I'm running mongrel_cluster and have been using it successfully for
quite a while now. However, today I ran a "cap deploy" and started
seeing the following error:

!!! PID file /var/www/apps/jco/shared/log/mongrel.8013.pid does not
exist.  Not running?

for each of the mongrels that should start up.

I've googled for solutions but haven't found any explaination.

How can this be rectified?

Thanks,
jeremy
_______________________________________________
Mongrel-users mailing list
Mongrel-users at rubyforge.org
http://rubyforge.org/mailman/listinfo/mongrel-users




More information about the Mongrel-users mailing list