[Mongrel] problem after mongrel_cluster 1.0.2 upgrade

Marco Rossi swmrrossi at yahoo.com
Sun Jul 15 20:49:40 EDT 2007


Dear all,

In the past, I've been successfully using 
mongrel_cluster following codahale setup [1]. 

Now I updated mongrel_cluster through gem to 1.0.2,
and my previosly worked config is not working anymore.


I report below a snip of one of logfile, it seems to
me  it is a missing gem problems, but this sounds
strange to me, because my config was ok before the
upgrade.

Does mongrel_cluster 1.0.2 require some additional gem
?


** Daemonized, any open files are closed.  Look at
/tmp/mongrel.8101.pid and /tmp/mongrel.8101.log for
info.
** Starting Mongrel listening at 127.0.0.1:8101
** Changing group to mongrel.
** Changing user to mongrel.
** Starting Rails with production environment...
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load --
/var/rails/test/config/environment (LoadError)
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/rails.rb:155:in
`rails'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:112:in
`cloaker_'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/configurator.rb:138:in
`call'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/configurator.rb:138:in
`listener'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:98:in
`cloaker_'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/configurator.rb:51:in
`call'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/configurator.rb:51:in
`initialize'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:83:in
`new'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:83:in
`run'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/command.rb:211:in
`run'
        from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:243
        from /usr/bin/mongrel_rails:16:in `load'
        from /usr/bin/mongrel_rails:16



[1] http://blog.codahale.com/2006/06/19/time-for-a-grown-up-server-rails-mongrel-apache-capistrano-and-you/


 
____________________________________________________________________________________
Don't get soaked.  Take a quick peak at the forecast
with the Yahoo! Search weather shortcut.
http://tools.search.yahoo.com/shortcuts/#loc_weather


More information about the Mongrel-users mailing list