[Mongrel] Content-Length: 0

Jack Baty jbaty at fusionary.com
Wed Jan 17 15:08:52 EST 2007


>> On Fri Jan 12, 2007 at 04:14:06PM -0500, Jack Baty wrote:
>>> While trying to debug a goofy XML loading issue in IE, I've found
>>> that Mongrel (latest) returns Content-Type: 0 with every request  
>>> on a
>>> particular (CentOS 4) server, yet not on my local (OS X) box. These
>>> both access identical Rails apps. This seems like a clue, but  
>>> thought
>>> I'd ask here if for some reason this is expected behavior. Both
>>> running Ruby 1.8.4. Both return identical HTML when asked.


For the record, I solved the problem by disabling compression (via  
Apache's mod_deflate) for XML. Not sure the Content-Length had  
anything to do with it. Rails-generated XML would fail, but identical  
static XML files worked fine. I still don't get it, but fixed is  
fixed and that's alright by me.




-- 
------------------------------------------------------------------------ 
--------
Jack Baty                  http://jackbaty.com/    (616) 822-5800
Fusionary                  http://fusionary.com/   (616) 454-2357
820 Monroe N.W. Suite 212
Grand Rapids, MI 49503



More information about the Mongrel-users mailing list