[Mongrel] Gem install from script

Graham Miller gmiller at marketcetera.com
Wed Feb 14 19:16:04 EST 2007

Hello all,
Apologies if this is not the right place for this question, but I thought
I'd start here.  We're trying to install the latest Mongrel from inside a
script.  Using 'gem install -v 1.0.1 mongrel' causes a prompt to come up
asking whether to install the "ruby" or "mswin32" variant.

Select which gem to install for your platform (i486-linux)
 1. mongrel 1.0.1 (ruby)
 2. mongrel 1.0.1 (mswin32)
 3. Cancel installation

If I don't want to have to write an expect script or something like that, is
there any way to specify on the command line that I want the "ruby" variant
so that I don't get this prompt?

Thanks in advance for any help.


Marketcetera Trading Platform
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070214/5096479f/attachment.html 

More information about the Mongrel-users mailing list