[Mongrel] mongrel_cluster 0.2.2 - plugin cluster::status does not exist?

Matte Edens matte at ruckuswireless.com
Tue Feb 13 17:59:06 EST 2007

Patrick Berry wrote:
> On 2/13/07, *Matte Edens* <matte at ruckuswireless.com 
> <mailto:matte at ruckuswireless.com>> wrote:
>     Hello all.  I've recently installed the 0.2.2 pre-release of
>     mongrel_cluster to try out the new --clean option.  However, after
>     installing, when I give a simple "mongrel_rails" command, the
>     cluster::status command is not listed.  The error I receive when I do
>     try and run the full "mongrel_rails cluster::status" is...
>     ERROR RUNNING 'cluster::status': Plugin /cluster::status does not
>     exist
>     in category /commands
>     I'm running a FreeBSD 6 VPS.  here is the mongrel gem list.
>     <snip>
>     Ideas?
> Removing the 0.2.1 version of the gem worked for me.
> gem uninstall mongrel_cluster (it will prompt for which version you 
> want to uninstall)
> Pat

Perfect.  Thanx Pat.  I used a "gem cleanup mongrel_cluster" which 
worked as well but that's more draconian since it removes ALL old 
instances instead of letting you pick and choose.  Which is fine for me

Doing that fixed the problem.  Now, finding out I have to run the 
command from inside the directory of a running app (duh), I'm getting 
the following errors output...

Checking 2 Mongrel servers...
ps: cmd: keyword not found
ps: no valid keywords; valid keywords:
Lost dog: 8000
ps: cmd: keyword not found
ps: no valid keywords; valid keywords:
Lost dog: 8001

The following line from the "status" function is incorrect (for my 
system at least)

ps_output = `ps -o cmd= -p #{pid}`

Running that line from the command line with a valid pid file gives me 

$ ps -o cmd= -p 84086
ps: cmd: keyword not found
ps: no valid keywords; valid keywords:
%cpu %mem acflag acflg args blocked caught comm command cpu cputime emul 
etime f flags ignored inblk inblock jid jobc ktrace label lim lockname 
login logname
lstart lwp majflt minflt msgrcv msgsnd mwchan ni nice nivcsw nlwp 
nsignals nsigs nswap nvcsw nwchan oublk oublock paddr pagein pcpu 
pending pgid pid pmem ppid pri
re rgid rgroup rss rtprio ruid ruser sid sig sigcatch sigignore sigmask 
sl start stat state svgid svuid tdev time tpgid tsid tsiz tt tty ucomm 
uid upr uprocp user
usrpri vsize vsz wchan xstat

It works after changing the line to read...

ps_output = `ps -o command -p #{pid}`

I'm not successfully receiving...

Checking 2 Mongrel servers...
Found dog: 8000
Found dog: 8001

matte - webmonkey
matte at ruckuswireless.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070213/181a79fe/attachment.html 

More information about the Mongrel-users mailing list