[Mongrel] mongrel_config has no output

Michael D'Auria michael.dauria at gmail.com
Sat Feb 10 17:24:21 EST 2007


I came back to this after not looking at it for a while and it looks like
you can get the plugin to work just by modifying one line:

<gems_path>/mongrel_config-0.3/lib/mongrel_config/app.rb:
[71] self << template.result(binding)

remove "self <<" as it is not needed and all works as expected.  Now i can
use this as a guide for my idea (finally!)

I hope this helps someone out.

.: Michael :.

On 12/19/06, Michael D'Auria <michael.dauria at gmail.com> wrote:
>
> I am not sure what i am doing wrong here, but no matter what i try i get
> no output from mongrel_config:
> $ mongrel_rails configtool
>
> $ telnet localhost 3001
> Trying 127.0.0.1...
> Connected to localhost.
> Escape character is '^]'.
> GET /config/ HTTP/1.1
>
> HTTP/1.1 200 OK
> Connection: close
> Date: Tue, 19 Dec 2006 05:33:16 GMT
> Content-Type: text/html
> Content-Length: 0
>
> Connection closed by foreign host.
>
> Here is a YAML dump of the $server object:
> --- &id001 !ruby/object:Mongrel::HttpServer
> acceptor: !ruby/object:Thread {}
>
> classifier: !ruby/object:Mongrel::URIClassifier
>   handler_map:
>     /log:
>     - !ruby/object:Mongrel::DirHandler
>       default_content_type: application/octet-stream
>       index_html: index.html
>       listener: *id001
>       listing_allowed: true
>       path: /home/michael/hhp/trebleNation/log
>     /favicon.ico:
>     - !ruby/object:Mongrel::Error404Handler
>       listener: *id001
>       response: |-
>         HTTP/1.1 404 Not Found
>         Connection: close
>         Server: Mongrel 0.3.20
>
>         NOT FOUND
>     /config/resources:
>     - !ruby/object:Mongrel::DirHandler
>       default_content_type: application/octet-stream
>       index_html: index.html
>       listener: *id001
>       listing_allowed: true
>       path: /usr/local/lib/ruby/gems/1.8/gems/mongrel_config-0.3/resources
>
>     /config:
>     - !ruby/object:Mongrel::Camping::CampingHandler
>       files: !ruby/object:Mongrel::DirHandler
>         default_content_type: application/octet-stream
>         index_html: index.html
>         listing_allowed: false
>         path: /
>       guard: !ruby/object:Mutex {}
>
>       klass: !ruby/object:Module {}
>
>       listener: *id001
> death_time: 60
> host: 0.0.0.0
> num_processors: 1073741823
> port: "3001"
> socket: !ruby/object:TCPServer {}
>
> timeout: 0
> workers: !ruby/object:ThreadGroup {}
>
> What's weird is that i can go to: http://localhost:3001/config/resources and
> see the erb template output with <% .. %>.  Currently I am running Mongrel
> 0.3.20 but i had the issue with 0.3.18 as well.  System is an Ubuntu Edgy
> on 2.6.17-10 kernel.
>
> Any help would be greatly appreciated,
>
> .: Michael :.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070210/256ac299/attachment.html 


More information about the Mongrel-users mailing list