[Mongrel] Mongrel service will not start on win32 w/ --prefix option

Guy Ridout ridoutspam at gmail.com
Wed Feb 7 00:46:18 EST 2007


Updating the mongrel gem ($ gem update mongrel --include-dependencies) did
the trick. Thanks again for your help. I definitely owe you a drink!

-BR :)

On 2/6/07, Luis Lavena <luislavena at gmail.com> wrote:
>
> On 2/6/07, Guy Ridout <ridoutspam at gmail.com> wrote:
> > Luis, I truly appreciate the quick reply and your eagerness to help.
> It's
> > refreshing to have software w/ service! Thank you.
> >
> > I tried running the command you suggest:
> >
> > C:\projects\rails-prod\wingate>ruby.exe c:\ruby\bin\mongrel_rails start
> -e
> > production -p 4001 -a 0.0.0.0 -l log/mongrel.log -P log/mongrel.pid -c c
> >  :/projects/rails-prod/wingate -t 0 -r public -n 1024 --prefix /wingate
> >  INVALID COMMAND: invalid option: --prefix
> >
> > It fails saying there is no --prefix option. Thinking maybe I don't have
> the
> > latest version, I did the following:
> >
> > C:\projects\rails-prod\wingate>gem update mongrel_service
> > Updating installed gems...
> > Need to update 23 gems from http://gems.rubyforge.org
> > .......................
> > complete
> > Attempting remote update of mongrel_service
> > Select which gem to install for your platform (i386-mswin32)
> >  1. mongrel_service 0.3.1 (mswin32)
> >  2. mongrel_service 0.1 (ruby)
> >  3. Cancel installation
> > > 1
> > Successfully installed mongrel_service-0.3.1-mswin32
> > Installing ri documentation for mongrel_service-0.3.1-mswin32.. .
> > Installing RDoc documentation for mongrel_service-0.3.1-mswin32...
> > Gems: [mongrel_service] updated
> >
> > Following this update, the command fails with the same message. Any
> ideas?
> >
>
> Mmm, did you update mongrel gem too?
>
> $ gem install mongrel --include-dependencies
>
> Mongrel version should be 1.0.1
>
> You should notice the "Mounting Rails at ..." line in the output:
>
> >mongrel_rails start --prefix /test
> ** Starting Mongrel listening at 0.0.0.0:3000
> ** Starting Rails with development environment...
> ** Mounting Rails at /test...
> D:0:Warning: require_gem is obsolete.  Use gem instead.
> ** Rails loaded.
> ** Loading any Rails specific GemPlugins
> ** Signals ready.  INT => stop (no restart).
> ** Mongrel available at 0.0.0.0:3000
> ** Use CTRL-C to stop.
>
>
> I tried the same here and it worked, maybe you have an older mongrel
> version.
>
> > Btw, I apologize if this post breaks the original thread. I'm a mailing
> list
> > newbie, and I didn't have my email settings correct, so there is nothing
> I
> > can reply to (assuming that is what I'm supposed to do!).
> >
>
> Its good that you bring this to mongrel list, we all started as newbies
> ;-)
> try replying to the last mail you get in the same thread (ex, mine, no
> mater it the Topic get modified with 're:' by your mail software).
>
> --
> Luis Lavena
> Multimedia systems
> -
> Leaders are made, they are not born. They are made by hard effort,
> which is the price which all of us must pay to achieve any goal that
> is worthwhile.
> Vince Lombardi
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070207/b8f482a5/attachment-0001.html 


More information about the Mongrel-users mailing list