[Mongrel] error when installing on jruby (fastthread dependency)

Stephen Bannasch stephen.bannasch at deanbrook.org
Sat Dec 22 22:29:15 EST 2007

At 9:45 PM -0500 12/22/07, Evan Weaver wrote:
>You have to cross package. Regular JRuby still has problems with
>signed gems and other gem-related things.
>  rake java package

I tried that with the latest svn co from jruby (5341) and mongrel (925) and still get the error:

can't convert YAML::JvYAML::Map into String
/Users/stephen/dev/jruby_trunk/jruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:738:in `add_file'

Should I file a new bug report? The original name: "error when installing on jruby (fastthread dependency)" doesn't describe the problem I am reporting now.

>Also, please follow the bug here:

See more details in the bug report.

>On Dec 22, 2007 5:53 PM, Luis Lavena <luislavena at gmail.com> wrote:
> > could you try running the gem build based on the generated gemspec file?
>> (it should be inside pkg/mongrel-1.1.1)
>> Maybe is failing in the Gem::Specification#to_yaml
> > (I don't have jruby to test it).

It's failing in the gempackage task:

Here's a truncated copy of the stack trace:

rubygems/package.rb:738:in `add_file'
rubygems/package.rb:738:in `open_from_io'
rubygems/package.rb:738:in `open'
rubygems/package.rb:790:in `open'
rubygems/builder.rb:68:in `write_package'
rubygems/builder.rb:68:in `build'
rake/gempackagetask.rb:86:in `define'
rake/gempackagetask.rb:85:in `when_writing'
rake/gempackagetask.rb:85:in `define'

More information about the Mongrel-users mailing list